- PR -

nantでVS2005を使いたい

1
投稿者投稿内容
mso
ぬし
会議室デビュー日: 2003/12/04
投稿数: 496
お住まい・勤務地: 宮城
投稿日時: 2007-09-26 11:24
msoです。

@ITの連載にnantの記事があり、便利そうなので
今やっているのですがどうしてもわからない箇所があります。

nantをインストールし、環境設定を行いました。
動作確認はnantのVersionを見ることで完了としています。

次にtest.buildを作成し、実行したところHello World!!が
表示されません。
「BUILD SUCCEEDED」は表示されます。

Webにあったサンプルを基に作成したのですが、
何が良くないのでしょうか?
ご教示ください。

実行時のnantの指定方法
nant -buildfile:test.build -nologo

コード:

<?xml version="1.0" encoding="utf-8"?>
<project name="TestProject" defalt="BuildAll">

<property name="Sample.Debug" value="true" />

<target name="Test">
<echo>
Hello World!!
</echo>
</target>

<target name="Test2" if="${Sample.Debug}">
<echo>テスト〜〜</echo>
</target>

<!-- ビルドプロセスを実行する -->
<target name="BuildAll">
<call target="Test" />
<call target="Test2" />
</target>

</project>



*****追加*****
件名を修正しました。

少しずつですがnantをやっていますが、
nantはVS2005をサポートしない様ですが、
どのようにかしてVS2005で動作させることは
できないのでしょうか???

VS2005を動作させようとしたときに、
コード:

[solution] Starting solution build.

BUILD FAILED

Microsoft Visual Studio.NET 2005 solutions are not supported.


とメッセージがでました。

何か対応方法をご存知であれば、教示ください。
よろしくおねがいします。

[ メッセージ編集済み 編集者: mso 編集日時 2007-09-26 17:27 ]
mso
ぬし
会議室デビュー日: 2003/12/04
投稿数: 496
お住まい・勤務地: 宮城
投稿日時: 2007-09-26 14:05
msoです。

解決しました。

projectのdefaultがうまく動作しないようでした。
nant -buildfile:test.build BuildAll
と、起動するターゲットを指定したら期待通りの
動作をしました。

Desmo
会議室デビュー日: 2003/05/23
投稿数: 8
投稿日時: 2007-09-26 14:28
defaultのつづりが間違ってますよね。

defalt -> default
mso
ぬし
会議室デビュー日: 2003/12/04
投稿数: 496
お住まい・勤務地: 宮城
投稿日時: 2007-09-26 17:28
引用:

Desmoさんの書き込み (2007-09-26 14:28) より:
defaultのつづりが間違ってますよね。

defalt -> default



あぁ・・・・恥ずかしいミスをしていました。
ご指摘ありがとうございます。
1

スキルアップ/キャリアアップ(JOB@IT)